TBrowser won't open (WSL Ubuntu)

Hello! I recently installed Root on WSL (Ubuntu 22.04.2, Windows 11) using the “Complete ROOT Installation Instructions for WSL” tutorial by @Axel. It worked perfectly fine on Thursday and I could open the TBrowser offline using Xming. Except that today I tried again and couldn’t open the TBrowser (see error below). Xming is working correctly because I can open “xclock” without issue! I can’t open the TBrowser online either.

Does anyone know what could’ve gone wrong? Are there any settings I should set up every time I open the ubuntu terminal?

Thank you!

EDIT: I fixed it! I’ll leave the thread open in case anyone has any idea on why it worked before.

I followed this instructions (which means i installed wslu as suggested) and added “source /home/laslus/root/bin/thisroot.sh” on the end of the .bashrc file (laslus being my PC name). Its working fine now, for both online and offline TBrowser!

ROOT version: 6.26/10


In one place I see root --web==off, which is wrong syntax. Please use single = sign.

On the Linux systems it is required to have xdg-open utility installed to use default web browser with ROOT. At the same time, one also can select favorite browser specifying --web=chrome or --web=firefox to ROOT executable. Of course appropriate browser should be installed


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.