TBrowser not Displaying any .root files

I am running files through a simulation software called Kassiopeia and with Root. I use the TBrowser in order to view plots of my data, but when I open it, there are no .root files anywhere, only xml files. My understanding is that there is supposed to be a corresponding .root file that I click on in order to view the plots. However they’re not there, why would that be?

_ROOT Version: 6.22/01
Platform: Not Provided
Compiler: Not Provided

Start by making sure that:

  • You are in the correct folder; note that in the TBrowser you need to double-click (not single-click) on a folder to open / change to it.
  • The root files are actually in that folder (check from outside ROOT)!
  • The filter (bottom left) says either “All Files” or “ROOT Files” (open the drop-down list and click on any of these; repeat just to make sure the filter is applied).
1 Like

Thanks for your response. The first and third are definitely true. As for the second one, I think so? The xml file I wrote is indeed in that folder, so I suppose the corresponding root file that gets created should be in the same folder.

Make sure, don’t just assume it :slight_smile:
What is the output of doing this on the ROOT prompt (while you are on the same folder where the root files are supposed to be)?

.! ls -al | grep -i "\.root"

Copy-paste this exactly as is, if you are on linux; on Windows use:

.! dir *.root

If the extension of the root files is capitalised (e.g. file.ROOT instead of file.root), the “ROOT files” filter may not show them, so use “all files”.

The output is:
-rw-rw-r-- 1 nalic nalic 417 Aug 13 00:31 .root_hist

where “nalic” is the directory I’m in. (where the xml file is)

Tried “all files” and that didn’t work either.

So the root files are not there, they were saved somewhere else, or not created at all; check your simulation software.

Ok. Is there a way to find out where else it may have gotten saved? I highly doubt that it wasn’t created at all, the simulation went completed without giving errors.

(Plus, this stuff worked fine in the past, then I had to uninstall it from my own machine and reinstall both Root and Kassiopeia onto an ssh server; while they both installed correctly, I’m now having the issue we’re talking about. If that info matters.)

Figured it out, nevermind. Thanks!

My output is exactly same, dastudillo how can we find where our root file is?

I don’t know the Kassiopeia software, so I don’t know how it is configured to save the files, maybe @nezir99 found out.
A brute force approach would be to search for all root files in all of your filesystem. On a linux terminal, you can do for instance:

cd /
find . | grep -i "\.root"

which may result in a very long list of files, among which you will have to look for your files. If you know for sure the name of the file (e.g. “myoutput.root”), you can change the “find” line to:

find . | grep -i "myoutput\.root"

an so on.

Towards the very end of the Kassiopeia output, like after you’ve run the simulation, a couple lines above where it says “…finished,” it tells you where the root files are. Specifically it says:

"[KSWRITER NORMAL MESSAGE] ROOT output was written to file: … "

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.