TBrowser cannot open

I am a sophomore student who just starts to use ROOT. Since Windows is my OS, I access ROOT via ssh into a cluster through Gitbush terminal. The problem arises as I type in command “new TBrowser”, and nothing pops out.

Can anyone help me with this problem? It would be really nice if you can explain the solution in detail as I really don’t know too much about ROOT.


this is not a ROOT issue but rather a missing X connection.
I am not familiar with Gitbush, but you can always open a graphical connection via ssh typing

ssh -XY myuser@myserver


In addition to forwarding the X11 information it is likely that you will need to install an X11 manager. Xming is a popular choice.

I would suggest just using the only -X flag for ssh as the -Y flag can open security issues.

Thanks for your instruction. I have tried to log in through ‘ssh -XY myuser@myserver’, and this time when I type in ‘new TBrowser’, an error occurs as followed:

Does it mean I have to download what you call a X connection? If so how should I do that?
Thanks a lot!

I also tried to log in as ‘ssh -X …’ or ‘ssh -Y …’ but nothing pops out after the ‘new TBrowser’ command, not even an error message. So does it mean I have to download the Xming package and then to log in normally?

The error message indicates that you don’t have an X11 server (Xming) running on your client. You need both the X11 server (Xming) and the X11 forwarding (ssh -X ...).

Install Xming and ssh with the -X flag and everything should work. I’m sure any person familiar with Linux at your institution would be able to provide additional assistance. (This has nothing to do with ROOT by the way, it is simply an issue of getting the graphics information from the server to your local client. You would also need X11 forwarding if you wanted to use gedit, for example.)

(As an aside, it is a bit easier to read terminal output as plain text placed in a code block. And it is probably less work for you.)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.