TBrower problem with version 5.13/04

I compiled ROOT 5.13/04 on my LinuxPPCGCC machine. My GCC verison is “gcc (GCC) 4.0.3”. Everything is functioning (so far) except that TBrower is not working.

After I type in “TBrowser test” in the interactive mode, following error messeges are shown — they are only the very first part of constantly-appearing errors. The broswer window does appear but it only shows distorted pattern inside the window where directory information is supposed to be shown. The frame and the menus are normal and I’m able to quite ROOT by clicking “file->quit” while the errors messages are still scrolling crazily. :slight_smile:

Error in : arrow_.xpm not found
Error in : arrow_down.xpm not found
Error in : arrow_
.xpm not found
Error in : arrow_.xpm not found
Error in : arrow_
.xpm not found
Error in : arrow_*.xpm not found
Error in : splitterv.xpm not found
Error in : splitterv.xpm not found
Error in : splitterv.xpm not found
Error in : splitterv.xpm not found
Error in : splitterv.xpm not found
Error in : splitterv.xpm not found
Error in : splitterv.xpm not found
Error in : required pixmap(s) missing

Warning in : No image
Warning in : No image

The errors below seem repeat continuously.

Root >
*** Break *** segmentation violation
Generating stack trace…
0x0d5b3dfc in TGLVEntry::DrawCopy(unsigned long, int, int) + 0xb8 from /usr/local/root/lib/root/libGui.so
0x0d54fb30 in TGContainer::DrawRegion(int, int, unsigned int, unsigned int) + 0x130 from /usr/local/root/lib/root/libGui.so
0x0d54acc4 in TGContainer::DoRedraw() + 0x34 from /usr/local/root/lib/root/libGui.so
0x0d5530f0 in TGClient::DoRedraw() + 0xc0 from /usr/local/root/lib/root/libGui.so
0x0d5536c8 in TGClient::ProcessOneEvent() + 0x48 from /usr/local/root/lib/root/libGui.so
0x0d55381c in TGClient::HandleInput() + 0x3c from /usr/local/root/lib/root/libGui.so
0x0d553864 in TGInputHandler::Notify() + 0x14 from /usr/local/root/lib/root/libGui.so
0x0f84949c in TUnixSystem::DispatchOneEvent(bool) + 0x98 from /usr/local/root/lib/libCore.so
0x0f7491e8 in TSystem::InnerLoop() + 0x38 from /usr/local/root/lib/libCore.so
0x0f74912c in TSystem::Run() + 0xe8 from /usr/local/root/lib/libCore.so
0x0f6ab590 in TApplication::Run(bool) + 0x4c from /usr/local/root/lib/libCore.so
0x0e245eec in TRint::Run(bool) + 0x2f8 from /usr/local/root/lib/libRint.so
0x10001cb4 in from /usr/local/root/bin/root.exe
0x0dec08ec in from /lib/libc.so.6
0x0dec0a34 in from /lib/libc.so.6

Recalling the compiling and running procedures, the only unusual things I did and found are:

  1. first, I did “./configure --prefix-dir=/usr/local/root” and finished the compilation by running “make”. Then, I changed my mind and did “./configure --prefix-dir=/usr/local/root --etcdir=/usr/local/root/etc” and redid the compiling by “make”. After, I did “sudo make install”

(and it did complain “g77 not found”)

  1. when I first ran root, it complained that it could not find libCore.so and I found all the share libraried are located in /usr/local/root/lib/root instead of /usr/local/root/lib as directed in the README file. So I made soft links for all of them in /usr/local/root/lib.

Any ideas about what is going on? Thanks!


It looks like not defined location of GUI icon path ($ROOTSYS/icons), where all icons in use should be. Could you please check do you have the listed .xpm files from the error messages in $ROOTSYS/icons directory? In addition, please check the settings of “Gui.IconPath:” in $ROOTSYS/etc/system.rootrc file and let us know.

Thank you, Ilka

Hello Ilka,

All the .xpm files are located in $ROOTSYS/share/root/icons instead of $ROOTSYS/icons.

File $ROOTSYS/etc/system.rootrc does have “Gui.IconPath:” set up correctly — it is set to “$(HOME)/icons:/usr/local/root/share/root/icons:.”.

Now, it seems that root is assuming some configurations instead of reading it from $ROOTSYS/etc.

Is it because that I did “./configure …” twice and it produced some inconsistancy?

Thanks a lot for your help!


According to my knowle if you run “./configure --prefix-dir=/usr/local/root”, ROOT will be installed in /usr/local/root/share/root directory and the system.rootrc file will be located in /usr/local/root/share/root/etc directory. May be it will be better if you reinstall root by running only “./configure --prefix-dir=/usr/local/root”.

Cheers, Ilka

Just tried but still the same errors. ROOT just doesn’t know where those icons are.

And “–prefix” has no effect on the “etc” directory — it is /etc/root if not specified otherwise.


In that case you may use “./configure --prefix-dir=/usr/local”. Anyway, I will let my colleagues who are installation experts about your problem.

Cheers, Ilka


Could you check there is no .rootrc file in your $(HOME) directory ?
That could be the cause of your problems (Root first take this one)



did you always do “make install”? Where do you find the icons? They should be in /share/root/icons. Check also the include/config.h file in the directory where you compiled ROOT to make sure the ICONPATH is as expected.

Cheers, Fons.

Thanks a lot for all your help!

I checked all the things you suggested but it seems to me that everything is all right.

It is either that the missing of “.xpm” files is not the real problem, or that the ROOT I compile doesn’t know how to get the configuration information out of the “etcdir”.

However, anything that does not have TBrowser involved worked smoothly so far.

I have exactly the same problem with root 5.12/5.13 (I tried both) on a Kubuntu System.
I did all the steps suggested in this thread and everything seems to be okay, is there any solution coming for this problem?

edit: version 5.12: root only complaints only that “arrow:.xpm not found"
version 5.13: root is missing the "splitterv.xpm and arrow_

using “–prefix-dir=/usr/local” will solve the problem. don’t know why.

thanks for help but though reinstallation using the prefix-option I still get the same error…

Make sure you have a CLEAN environment, namely, clean up all the ROOT environmental variables.

If possible, clean up the previous installation also — “make uninstall” before you change your configration.