Tbranch address issue

Dear all,
I have a root-based program which loops on a tree, calculate some new quantities and store them in the tree.
It worked for several root-trees but one.
Adding some debugging printouts I discovered this:

for the event making the program crashing.

For the events before this I get:

Those branches are declared this way:

   //  new branches
   TBranch        *b_strip;
   TBranch        *b_nClusters;
   TBranch        *b_clustPH;
   TBranch        *b_clustPlaneId;
   TBranch        *b_clustMul;

and implemented in this way:

   b_clustPH = fChain->Branch("clustPH",clustPH,"clustPH[nClusters]/D");

I run the program with gdb and I get

In attachment you have class, main program and root file.
Run it in this way:

Root version is 5.26 on a SL 4.8 system.

Any help will be really appreciated.

testLoop.cpp (358 Bytes)
BEAM_3266.root (72.3 KB)
PomoneStruct.h (5.94 KB)
PomoneStruct.cpp (6.26 KB)

Hi all,
I was not reserving enough entries in arrays for new variables.

Sorry for the noise.