Symbol lookup error

Hi everyone!

Unfortunately I can’t launch some project. I have this error:

symbol lookup error: /home/user/root/lib/ undefined symbol: _ZN4ROOT8Internal19RConcurrentHashCollD1Ev

How I can solve it?

ROOT Version: 6.14/00
Platform: Kubuntu 18.04
Compiler: gcc 7.3.0


Can you try whether the error persists with the latest bugfix release 6.14/04?


Unfortunately it still doesn’t work with the same error.

I reinstalled Geant4 and now all right…almost. I have another error.
Cmake can’t found some files:


How can I add them. Without them, the project is not compiled.

So I understand that you’re not using stand-alone ROOT but ROOT is part of a larger CMake project? If it is an open project, e.g. on github, can you point us to the source code? For CMake related errors, @amadio might be able to help.

Have you removed the build directory since upgrading ROOT? CMake caches some variables an d you made have the two versions mixed up.

Thanks a lot! It was solution…but…
At first I must admit. I’m novice))

After deleting build-directory, old root version I started to launch basic geant4 examples…some of examples. Another one was needed old version of opengl and qt libraries. I managed with this problem, but forgot changed library to new one before restart my system (I used ldconfig). It was my fault. After rebooting I couldn’t launch Kubunt, even in recovery mode. I also couldn’t launch terminal(very strange). Nothing worked.

I reinstalled system, Qt, Root, Geant4(without problems) and now it works pretty well,…))) almost…
One of a Geant4 project have a segmentation violation. I will try to manage with it. In other case I will ask you again.

Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.