Suppressing output when fitting histograms

I am fitting a histogram, hist, using

hist->Fit(“gaus”, “q”);

Is there any way I can suppress all of the output from the fit, including the final result? I am already using the q option for quiet mode.

I wish to do this because I am running ~10000 fits for pull studies and saving the result of each fit straight to a histogram. Printing out the result of each fit takes longer than the rest of the code takes to run and I don’t need the print out.

Thank you. Nicola

When using the option “q” you should not get any output.
Which version are you using?


Ah, you are right. I had missed the “q” option somewhere in my code after all. I’m sorry not to have checked carefully enough before posting. Thank you for your swift response.