Struggling with openinig the TBrowser() on WSL 2

hello everyone, could you please see if you can help me with this problem

Hello @mustapha_Ch ,

and welcome to the ROOT forum!

Does running root --web=off instead of root as the message on screen suggests help?


1 Like

Hello Equiraud, thank you for your answer, I tried before with many steps till I reached these results.
but in the end, I decided to ask in this best forum. the problem is solved thank you.

Although xdg-open might not be working correctly (likely because none of those browsers are installed, none of them would be default in WSL, as Windows comes with one built in); you can copy the URL at the bottom, into a web browser on your Windows installation; and it should work essentially identically.

The problem is it can’t open the browser, not that it can’t open the web server the browser would connect to; that bit usually works fine.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.