Struggling to import ROOT on lxplus

Dear experts.

I am trying to run a script on lxplus. When I run:

import ROOT

it returns the following error:

Traceback (most recent call last):
  File "", line 1, in <module>
    import ROOT
  File "/usr/lib64/python2.7/site-packages/ROOT/", line 28, in <module>
    import cppyy
  File "/usr/lib64/python2.7/site-packages/cppyy/", line 131, in <module>
    from ._cpython_cppyy import *
  File "/usr/lib64/python2.7/site-packages/cppyy/", line 37, in <module>
    inspect._old_isfunction = inspect.isfunction
AttributeError: 'module' object has no attribute 'isfunction'
(base) [xmapekul@lxplus787 inspect]$ root version
Warning in <TApplication::GetOptions>: macro version not found

Please let me know what the problem could be.

_ROOT Version:6.24/06
_Platform: lxplus


I just tried on lxplus and I don’t see the error, with either python3 or python2.

Could you perhaps relogin to another lxplus node and try again?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.