SQLite problem with linking

Dear ROOTers
I would like to use SQlite in my application. I wrote my application. Code looks like:

TString datafile = "sqlite://$HOME/mpd_database/database.sqlite"; fSQL = TSQLServer::Connect(datafile,user, pass);
When I run make everything is fine but when I run my code I get error:

This error apear in line:

My library path is ok but I don’t have libSQLite - I have libsqlite3 instead.
Any Idea what I should change to force my code to work?

root-config --features | grep -i sqlite
or see if you get “yes” from:
root-config --has-sqlite
or see if you have “libSQLite.so” and “libSQLite.rootmap”:
ls -al root-config --libdir/libSQLite.*

If not, you need to recompile your ROOT from scratch. Make sure that the “./configure” step found your “sqlite3.h” and “libsqlite3.so” -> see the “config.log” file (if everything went well, in the end of this file you should also see “Result: Enabled support for … sqlite, …”).

Yes my sqlite seems to be disabled but i don’t know how enable it. I modified scripts for installation - now i configure with --enable-sqlite
at end configuration logs i have something like this:

I also see in logs that necessary libs and headers has been found.

EDIT: I found this file, for some reason after rebuilding root new library hasn’t been copied to my new place, so I moved it’s by hand and now works :smiley: