[solved] Installation failure


I’ve just tried to install the 4.04.02 Production Version of ROOT under Ubuntu 5.10 from sources on my laptop, but the “make ./configure” ends with :

In file included from afterbase.h:34, from blender.c:32: asim_afterbase.h:230: erreur: syntax error before ‘mode_t’ asim_afterbase.h:230: attention : pas de point virgule à la fin de la structure ou de l'union {Warning : no semicolon at the end of the structure or the union} asim_afterbase.h:231: attention : la définition de données n'a pas de type ni de classe de stockage {Warning : data definition has no type nor stocking class} asim_afterbase.h:233: erreur: syntax error before ‘}’ token make[1]: *** [blender.o] Erreur 1 make[1]: quittant le répertoire « /home/goug/root/asimage/src/libAfterImage » {leaving directory "/home/[...]"} make: *** [asimage/src/libAfterImage/libAfterImage.a] Erreur 2
(between {} is a translation attempt for non-french-speaking… :blush: )

However, I had no problem installing the same version under Mandriva 2old006 on my desktop… What could I do to solve this problem ?


PS : I said there was no problem under Mandriva, because it seems to work fine, but in fact that I have to set ROOTSYS each time I want to run ROOT, I think this is because I forgot the argument “–prefix=/usr/local” to the “./configure” command… So do I really need to reinstall it or does it not care and is it a way to set definitively ROOTSYS ?

this is being worked on, see savannah.cern.ch/bugs/?func=deta … m_id=14068

Ok, thank you Axel, I’ll follow this.

And for the Mandriva problem, does somebody have any suggestion ?

you can either re-run configure, make, make install, or you can set ROOTSYS in some script.

Ouch ! This is so long to run… I think I will use the second possibility for the moment. Thanks.