Severe problem with TGTextEntry - urgent help needed!

Dear Rooters

The following severe problem is reproducible not only in my
gui application and the attached macro “guiTestKeys.C”, but
also in the root tutorial “guitest.C”!

When I run the tutorial macro “guitest.C” and try to type
text into TGTextEntry “fTestText”, the following keys of
the keyboard give no response: “t”, “o”, “f”, “h”.

When I run the attached macro “guiTestKeys.C”, the following
keys give no response: “o”, “f”.
Commenting out fBrowseUTBtn button (lines 343-347), then only
the “f” key gives no response.
Commenting out fBrowseUTBtn and CreateMenuBar() (line 145),
then ALL keys respond (of course, on my german keyboard
pressing the german umlaut keys “ä”,“ü”,“ö” give no response)

The attached macro is a stripped down version of a pretty
complex frame, and my gui application consists of many very
complex frames:
I realized that with increasing complexity more and more keys
can no longer be pressed, until in my gui application almost
no key does respond.

I have mentioned this behavior first one week ago, see:
however, at that time I could not present an example.

It would be great if this problem could be solved as soon as
possible, since I want to present my program at a conference
end of July, and not being able to input anything would
prevent me from being able to demonstrate my program :frowning:(

I am running root 4.00/04 cvs from April 29 on MacOSX 10.3.1,
since I am still not able to compile the new root cvs version.

Thank you in advance
Best regards
guiTestKeys.C (10.4 KB)

This problem had already been solved a few weeks ago. Move to 4.00.06a or the
newly released 4.00/08