Setting up ROOT environment

Please read tips for efficient and successful posting and posting code

ROOT Version: 6.22/07
Platform: Ubuntu 18.04.5 LTS
Compiler: gcc 7.5.0

I installed the ROOt in a new system with the following command:

$ git clone --branch v6-22-00-patches root_src
$ mkdir root_build root_install && cd root_build
$ cmake -DCMAKE_INSTALL_PREFIX=../root_install ../root_src
$ cmake --build . -- install -j10
$ source ../root_install/bin/

But when I tried to run ROOT from another terminal window, it won’t run.

Command 'root' not found, but can be installed with:

sudo snap install root-framework

So I tried to set it up from new windows. It works after running the source... command, but not in new windows.
Setting the environment like this worked in my other systems. I can’t figure out what’s wrong…
Any idea on how to solve this problem will be appreciated.

With thanks and regards,

the source ../root_install/bin/ is valid for the current terminal session only. If you open a new terminal Window, you have to call source ../root_install/bin/ again

Thanks @bellenot for the quick response.
But in earlier version (v6.16 to be exact) the command source ROOT_DIRECTORY/bin/ in a new window worked. Is this behavior specific to this version of ROOT? Can you give me any idea how to implement it?


What do you mean? As I said, you have to do it in each new window. And it was the case also in older versions of ROOT. If you don’t want to call every time, you can add it in your .basrc

Thanks, @bellenot. Now it works. But in my other system I just checked this line is not in .bashrc, I had just run it from a new window and that was it.
Although it is working fine in this one. Thanks a lot again.


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.