Setting environment variables ROOT install

Dear all,

I am having trouble with setting correctly the environment variables to run ROOT. I have just installed as operating system Ubuntu 12.04 32bits.

After building successfully ROOT, I followed the documentation to set the environment variables, that is to say, on terminal

export ROOTSYS=/root
export PATH=$PATH:$ROOTSYS/bin

Then, after typing on terminal, placed on $HOME/root, “. bin/”, ROOT was running. Eveything ok until here according to guides.

The problem arises when I reboot the computer. Then, when I type on terminal “root”, root does not run. I tried to solve this by writting the three “export” lines above on “.bashrc” but nothing gets better. I realised that I have to type on terminal every time “. bin/”, when I’m on $HOME/root, and then ROOT runs. I think this is not normal.

Somebody knows how to set the environment variables for ROOT in a definite way? So, I just type “root” on any terminal and ROOT runs.

Thanks in advance&sorry if this question is stupid…

Well, there are different command shells (with similar scripting languages), different ways to set environment variables, different ways to execute scripts when you log in. None of them is a ROOT related topic., indeed, is a nice script to set variables you need, up to you how and when you execute it.
I think any book on linux/unix or bash/ksh/csh has a lot of examples how to do it.
Or even better - read Ubuntu’s forums/docs on how to do this, since things sometimes are quite different/special on Ubuntu (starting, I think, from 11.x releases). For example, on my Ubuntu 12.04 (in a virtual box) I can execute from .bashrc (which is in my home directory) and so if I open the terminal (start bash), I can use ROOT immediately without setting any enviroment variables manually.