Seg fault with ROOT and gcc-3.x


Ever since I’ve upgraded to gcc-3.x compilers I’ve had strange problems with ROOT - usually generating this message:

*** Break *** segmentation violation
Generating stack trace…

and usually accompanied by a cryptic (to me) error message:

unknown demangling style `gnu-new-abi’

I’m stilll having problems with this. Today I checked out the current tag of ROOT from cvs and built on my machine. My compiler now is:
gcc version 3.3.2 20030908 (Debian prerelease),
although I’ve tried many compilers since gcc-3.2 in the past with no success. (I never had problems with ROOT using the gcc-2.95/6 compilers.)

I thought that this might be an LD_LIBRARY_PATH or PATH problem, so I even tried making these as minimal as possible, but still no joy.

Any ideas would be appreciated.

Kind regards


If you have moved from gcc2.95 to gcc3.3, make sure to:
make distclean

check the consistency of PATH and LD_LIBRARY_PATH

When you get a crash, use gdb to get the traceback. see