Seg Fault using SetLogy in GUI v3.10/00

Hello all,
I’m running 3.10/00 on RH 8. I always get a seg fault when drawing the histo “K0vXsq” from the attached file and setting and unsetting SetLogy in the graphical TCanvas menu. Here are my steps:

  1. Draw the histo “K0vXsq”
  2. Right click on canvas and SetLogy
  3. Right click again and unset SetLogy

Below is the backtrace:

*** Break *** segmentation violation
 Generating stack trace...
 0x415f0e62 in pthread_cond_broadcast + 0x32 from /lib/i686/
 0x420f0caf in pthread_cond_broadcast + 0x2f from /lib/i686/
 0x410fddef in <unknown> from /usr/X11R6/lib/
 0x410dfe70 in <unknown> from /usr/X11R6/lib/
 0x410e148b in _XSend + 0x26b from /usr/X11R6/lib/
 0x410c5443 in XDrawPoints + 0x203 from /usr/X11R6/lib/
 0x410507c5 in TGX11::DrawPolyMarker(int, TPoint*) + 0x63 from /usr/root/lib/
 0x40fb5e8e in TPad::PaintPolyMarker(int, double*, double*, char const*) + 0x1fc from /usr/root/lib/
 0x416a48b2 in THistPainter::PaintScatterPlot(char const*) + 0x588 from /usr/root/lib/
 0x416a7e11 in THistPainter::PaintTable(char const*) + 0xa5 from /usr/root/lib/
 0x4169a0fc in THistPainter::Paint(char const*) + 0x22c from /usr/root/lib/
 0x40819cae in TH1::Paint(char const*) + 0x68 from /usr/root/lib/
 0x40fb3e30 in TPad::PaintModified() + 0x400 from /usr/root/lib/
 0x40f98dae in TCanvas::Update() + 0x78 from /usr/root/lib/
 0x400ed1cb in TContextMenu::Action(TObject*, TToggle*) + 0x137 from /usr/root/lib/
 0x412b6d2c in TRootContextMenu::ProcessMessage(long, long, long) + 0xb0 from /usr/root/lib/
 0x41253226 in TGFrame::HandleClientMessage(Event_t*) + 0x4a from /usr/root/lib/
 0x41252f5a in TGFrame::HandleEvent(Event_t*) + 0x1d0 from /usr/root/lib/
 0x41236ceb in TGClient::HandleEvent(Event_t*) + 0xd7 from /usr/root/lib/
 0x412369e4 in TGClient::ProcessOneEvent() + 0x6e from /usr/root/lib/
 0x41236a6e in TGClient::HandleInput() + 0x28 from /usr/root/lib/
 0x412355ea in TGInputHandler::Notify() + 0x22 from /usr/root/lib/
 0x401c45b2 in TUnixSystem::DispatchOneEvent(bool) + 0x3a from /usr/root/lib/
 0x4012fdb3 in TSystem::InnerLoop() + 0x25 from /usr/root/lib/
 0x4012fd41 in TSystem::Run() + 0x7b from /usr/root/lib/
 0x400e03f6 in TApplication::Run(bool) + 0x30 from /usr/root/lib/
 0x40e0ebdb in TRint::Run(bool) + 0x311 from /usr/root/lib/
 0x08048890 in main + 0x90 from /usr/root/bin/root.exe
 0x420158f7 in __libc_start_main + 0xc7 from /lib/i686/
 0x08048711 in _Unwind_Resume + 0x35 from /usr/root/bin/root.exe

I have also checked on 3.05/05 with the same file and there is no seg fault there. Is this reproducible for others?

dataomegalyzed788s_fermterm.root (126 KB)

This problem had been solved in 3.10/01


I have just downloaded and tried it on 3.10/01 and the behavior is the same as on 3.10/00. Are you unable to reproduce this with the attached file on 3.10/01?



I cannot reproduce the problem switching between/lin/log scale along Y
for the histogram you indicated. May be you are following a different
sequence of actions? Let me know.


I went through again and did exactly as I said in the 1st post. I got a seg fault 8 out of 10 tries. I am using the precomplied RH 7.3 binaries for gcc 3.2 on a vanilla RH 8. Maybe there’s a conflict between the RH 7.3 binaries and RH 8?


I compiled ROOT from source and the problem is gone now. It must be an RH 8 imcompatibility issue with the RH 7.3 binaries.