runProof.C Error in compiling


ROOT Version: 6.26/00
Platform: CentOS 8.5.2111
Compiler: g++ 8.5.0


I tried to load/compile runProof.C using .L $ROOTSYS/proof/runProof.C+ and got a lot of errors of the type

$ROOTSYS.proof/runProof.C:984:46: error: member access into incomplete type 'TObjString'
      fn.Form("%s/event_%d.root", os->GetName(), i);
$ROOTSYS/include/TFileCollection.h:36:7: note: forward declaration of 'TObjString'
class TObjString;

similar errors also occur for TMap (forward declaration in TUrl.h in this case).

But the main reason I tried to run this was to figure out why I’m getting errors like this:

<time> <date> Wrk-0.0 | Error in <TCling::LoadPCM>: ROOT PCM $ROOTSYS/<selector name>_C_ACLiC_dict_rdict.pcm file does not exist

when I try to use

gSystem->CompileMacro(<selector name>.C, "kgOs");

inside a program. The pcm-file does exist in the local directory where the program was run and I checked and this error does not appear with ROOT 6.24/06.

Is there any way to add paths to the ones searched? As far as I can see ROOT 6.26/00 only considers paths under $ROOTSYS at the moment.

@vvassilev can give a hand perhaps? Thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.