Running ROOT with Geant4


I’m trying to run Geant4 examples with root installed & configured, but I’m keep getting the error:

dyld: Library not loaded: @rpath/libG4Tree.dylib
  Referenced from: /usr/local/bin/exampleB1
  Reason: image not found

I’ve runned through all the relevant threads and tried all the suggested solutions, but nothing have worked yet, are there any previous experiences with this particular issue? Maybe it is not related to ROOT but rather G4 and the integration between the two?

Thanks in advance,

ROOT Version: v6.22.0
Platform: MacOS Catalina
Compiler: gcc

The problem is that the linker cannot find the libraries. See man dyld for more information.
You may need to set DYLD_LIBRARY_PATH or rebuild the example (and maybe Geant4) with the right configuration.

1 Like

Thank you for your answer.


I have something like this, even tried turn csrutil off on my mac, did not work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.