Running root on windows 7

I have just installed on my laptop which is running on windows 7

The installation worked fine and I can start root properly and execute the simple commands at the beginning of the primer (function plotting etc…)

Then comes section 2.2 with its “vector” example. and there I’m all lost root keeps telling me the vector symbol hasn’t been defined in this scope. I tried it both as a script and as a command line… It’s all the same. I browse through the forum and website for a solution but I couldn’t find anything…

I intend to run some more complex data analysis scripts that a friend wrote in C++ using root libraries. It doesn’t work either and here again I don’t find anything that seems to tackle my issues…

Is there somewhere I can find a tuto or some information for people running root on windows ?(and not willing to switch to linux…)

Hi Abazir,

are you working with ROOT6?


I’m using root 5.34.36 since ROOT 6 doesn’t run on windows…

Actually I found a clue on an university site that helped me achieving my goals ! So it’s fine now even if haven’t solved the problem with vector class used in the primer…


The problem is that the primer is using features only available in ROOT 6 (e.g. C++11 language features), so this will never work with ROOT 5.

Cheers, Bertrand.

The problem is that “ROOT 5 Primer” disappeared (please “restore” it).