Running ROOT on the new slc5 web server


I sent this to but they told me to contact ROOT support:

I am trying some cgi functionality on the new slc5 web server, and I wonder how to execute root on it.

I have made a test-script to illustrate my problem:

I run two different compilations of root (i686-slc5-gcc43-dbg and slc4_ia32_gcc34) on both the new and the old platform:

old slc4:
new slc5:

As you can see slc4_ia32_gcc34 works on the old server (this is what I used to run before), but none of them works on the new one!

Is there some additional things I need to do? Am I trying the wrong root version? Set some special environment?


Johan Lundquist


you’re missing a few libraries on your SLC5 installation: probably none of the X11-related packages have been installed on the slc5 machine.

Cheers, Axel.

Thanks Axel, so I guess I must get back to the help-desk and ask them to install these packages? Judging from the previous reply from them, they don’t seem to think this is a problem on their side!

Solved … I thought I was running the 64 bit version but apparently I didn’t!