Running ROOT... failed: NO idea

I just re-running my root again since I have not used it for a while. When I tried to plot some data on a Tcanvas using TGraph I get the following error:

bash-3.2$ root plot.C

  •                                     *
  •    W E L C O M E  to  R O O T       *
  •                                     *
  • Version 5.15/06 24 April 2007 *
  •                                     *
  • You are welcome to visit our Web site *
  •      [](            *
  •                                     *

Compiled on 2 May 2007 for linux with thread support.

CINT/ROOT C/C++ Interpreter version 5.16.19, March 16, 2007
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0]
Processing plot.C…
dlopen error: wrong ELF class: ELFCLASS64
Load Error: Failed to load Dynamic link library /home/cmosquer/root/lib/
Error in TGHScrollBar::TGHScrollBar: arrow_.xpm not found
Error in TGVScrollBar::TGVScrollBar: arrow_
.xpm not found

*** Break *** segmentation violation
(no debugging symbols found)
Using host libthread_db library “/lib64/”.
(etc…etc… etc)

bash-3.2$ gmake -v
GNU Make 3.81
Copyright © 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A

This program built for x86_64-redhat-linux-gnu

I was hoping I could solve the problem by rebuilding my root source, so that is what I did:
make clean

But I keep having this same error. Any advise/suggestions?

Cristian M.

I suggest to start from version 5.19