Run Madanalysis5 root-config "command not found"

_ROOT Version:6.26/10
_Platform:Ubuntu 20.04.5 LTS
_Compiler:gcc 8.4.0; Python 3.8.10

When I ran


Under Madanalysis, it did not work, in log file had errors like:

make: /home/si/Dropbox/Linux/Software/madanalysis5/tools/SampleAnalyzer/ExternalSymLink/Bin/root-config: Command not found
g++ -Wall -O3 -fPIC -I/home/si/Dropbox/Linux/Software/madanalysis5/tools/  -o root/TreeReaderBase.o -c root/TreeReaderBase.cpp
make: /home/si/Dropbox/Linux/Software/madanalysis5/tools/SampleAnalyzer/ExternalSymLink/Bin/root-config: Command not found
g++ -Wall -O3 -fPIC -I/home/si/Dropbox/Linux/Software/madanalysis5/tools/  -o root/RootMainHeaders.o -c root/RootMainHeaders.cpp
make: /home/si/Dropbox/Linux/Software/madanalysis5/tools/SampleAnalyzer/ExternalSymLink/Bin/root-config: Command not found
g++ -Wall -O3 -fPIC -I/home/si/Dropbox/Linux/Software/madanalysis5/tools/  -o root/ROOTReader.o -c root/ROOTReader.cpp
root/TreeReaderBase.cpp:26:10: fatal error: TChain.h: No such file or directory
 #include <TChain.h>
In file included from root/RootMainHeaders.cpp:26:
/home/si/Dropbox/Linux/Software/madanalysis5/tools/SampleAnalyzer/Interfaces/root/RootMainHeaders.h:30:10: fatal error: TROOT.h: No such file or directory
 #include <TROOT.h>
compilation terminated.
compilation terminated.
make: *** [Makefile_root:90: root/TreeReaderBase.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [Makefile_root:90: root/RootMainHeaders.o] Error 1
root/ROOTReader.cpp:29:10: fatal error: TROOT.h: No such file or directory
 #include <TROOT.h>
compilation terminated.
make: *** [Makefile_root:90: root/ROOTReader.o] Error 1

The interface showed the errors:

MA5: Checking optional packages devoted to data processing:
MA5:      - Zlib                     [OK]
MA5:      - FastJet                  [DISABLED]
MA5-ERROR: impossible to execute the commands: /usr/bin/root-config --libdir --incdir --version
MA5:      - Root                     [OK]
MA5:      - Delphes                  [DISABLED]
MA5:      - Delphes-MA5tune          [DISABLED]

Thank you!

Installing ROOT

I installed by

sudo snap install root-framework

Is that not working?
Sorry for this naive question as I am a beginner of Linux user.

And if I run

root-config --version

It will show:


And I found the root-config is under folder:/snap/bin/root-config.
Also if I type “root”, the interface will appear, which means it was installed successfully.

It seems your tool is incompatible with snap.
I guess you need to install ROOT (appropriate for your system/compiler/python versions) using some “more traditional” method.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.