Home | News | Documentation | Download

Run combinedFit.C tutorial using ROOT 6.20.02 on Windows 10

Hi,

I tried to run combinedFit.C tutorial (https://root.cern.ch/doc/master/combinedFit_8C.html) using ROOT 6.20.02 on Windows 10 by the command

.x combinedFit.C+

however, I got the message

Info in TWinNTSystem::ACLiC: creating shared library C:/root_v6.20.02/macros/combinedFit_C.dll
input_line_12:8:25: error: use of undeclared identifier ‘Ic’
“c:/root_v6.20.02/etc” -Ic:/root_v6.20.02/etc//cling -Ic:/root_v6.20.02/include"",
^
Error in : Dictionary generation failed!

I can run it by using simply the command

.x combinedFit.C()

but when I try to run it again without closing the ROOT, I got

Assertion failed: Val && “isa<> used on a null pointer”, file C:\build\ws\BUILDTYPE\Debug\LABEL\windows10\V\6-20\root\interpreter\llvm\src\include\llvm/Support/Casting.h, line 106

and then the ROOT closes. Is it possible to get rid of this problem and not to reopen ROOT when I run this code multiple times?

Unloading is a known issue (unless @Axel tells it should work), and there is not much we can do about it for the time being… And I’l see what I can do for the ACLiC issue. For now, you most probably have to exit ROOT and start again to re-run your macro. (we’re still working actively to fix the remaining issues on Windows)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.