RootX11ErrorHandler problem

Hi Rooters,

I have installed ROOT locally on my laptop where I have Fedora 18 using KDE environment.
Whenever I try to launch a TBrowser or draw some distributions from branches in a TTree, I get the following error:

Error in : BadAlloc (insufficient resources for operation) (TGFrame XID: 262, XREQ: 153)
TGFrame: 262

I have been looking into the posts to see if some had similar errors and I found that this has to do with firefox which uses too many colors and that it should be closed. I closed Firefox but however i still get the same error.

Does anyone have any idea how to solve or work around this problem ???

Thanks a lot.


Same problem here :

$ root -l 
root [0] TBrowser bb
Error in <RootX11ErrorHandler>: BadAlloc (insufficient resources for operation) (TGFrame XID: 215, XREQ: 152)
TGFrame:        215

Running on 3.5.7-gentoo, using x11-base/xorg-server-1.13.1 and x11-base/xorg-x11-7.4-r2.
I can reproduce this problem with different window managers (KDE and xmonad) and with different root versions: sci-physics/root-5.32.03-r2 (x86) and with sci-physics/root-5.34.05 (~x86).
I compile with gcc, either v4.6.3 or v4.5.4.

‘free’ tells me that I am not running out of memory.
I see that a similar problem had been reported a long time ago (2004–2006)
[url]Root & mozilla
[url]What does “RootX11ErrorHandler: BadAlloc” mean?
[url]Error in <RootX11ErrorHandler>:
but I cannot see any solution reported there.

Any idea about how to fix this?

Thank you,


OK, I see that the problem is described here

[url]Problem with fedora 18
and it’s due to this particular version of xorg.

Marking this thread as solved.
Sorry for the noise.