<RootX11ErrorHandler>: BadValue - X_OpenFont problem

Hello,

I’m trying to install ROOT on my system. It works, but when I
want to use editor in canvas I’m getting the following error:

Error in : BadValue (integer parameter out of range for
operation) (XID: 50332051, XREQ: 45)

and then ROOT hangs (and even Ctrl+C won’t stop it, only kill -9). Error can be reproduced in various ways, one of the examples is the following:

t=TPaveLabel(0.4,0.4,0.8,0.8,“t”)
t.Draw()
and then click View->Editor and then click on TPaveLabel in the canvas.

When I’m running ROOT on another machine over ssh the problem disappears.

Some details about my system: linux-2.6.15, xorg-6.8.2 with nvidia drivers.
I’ve tried ROOT version 4.02/00 compiled from sources (by gentoo emerge) and version 5.08/00 downloaded from root.cern.ch.

Thanks for any help.

Hi Vladimir,

You can run the macro guitest.C from $ROOTSYS/tutorials and select Test menu / Font Dialog… Do you see font names listed in the Font Dialog? If the font list is empty, the ROOT fonts (located in $ROOTSYS/fonts) are not available for your system.

Cheers, Ilka

Hello,

Thanks for your answer. The problem was solved by deleting sybmol.ttf font grabed from MS Windows.