$ROOTSYS/test cannot be found


I am a pretty new for root. I installed homebrew and then root on mac. The version I installed is 6.28.04. I am trying to run the copytree3() script, but I got “unknown type name Event” error. I tried to locate $ROOTSYS/test, but then I found that there is no such a file with the name “test” installed there. I was reading the ROOTUsersguide, and a file (which includes hsimple.cxx, MainEvent.cxx,… and so on) with the name “test” should be installed somewhere, but I could not find it anywhere. There is no .cxx file installed in root.

The root I installed worked for the short scripts created by myself which I thought the installment was OK.

May I ask if there is anyway that I can download the “test” file anywhere? Or the “test” file was deleted after some version of root?

Hi @HaoZ ,

I have just tried to execute the copytree3.C tutorial and I can reproduce the missing executable problem. I have opened a github issue to keep track of the issue Missing `test` installation folder in $ROOTSYS · Issue #13548 · root-project/root · GitHub

If you are able to write your own applications using ROOT (in either C++ or Python) and those work fine, then I would say there is nothing particularly wrong with your installation. Let me know if you experience other issues.


Hi Vincenzo,
Thank you so much for your response. I will also keep an eye on the on the github issue you posted.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.