$ROOTSYS/etc/system.rootrc GQt problem

I am trying to plot histogram with the following errors:

Error in TUnixSystem::DynamicPathName: GQt[.so | .sl | .dl | .a | .dll] does not exist in /usr/local/root/lib:/usr/local/qt-3.3.8/lib:/usr/local/root/lib::.:/usr/local/root/lib::/usr/local/root/cint/cint/stl
Warning in TCanvas::ResizePad: c1 width changed from 0 to 10

Warning in TCanvas::ResizePad: c1 height changed from 0 to 10

Warning in TPad::ResizePad: pad1 width changed from 0 to 10

Warning in TPad::ResizePad: pad1 height changed from 0 to 10

Warning in TPad::ResizePad: pad2 width changed from 0 to 10

Warning in TPad::ResizePad: pad2 height changed from 0 to 10

SysError in TFile::TFile: file fillrandom.root can not be opened (Permission denied)
Error in TROOT::WriteTObject: The current directory (Rint) is not associated with a file. The object (form1) has not been written.
Error in TROOT::WriteTObject: The current directory (Rint) is not associated with a file. The object (sqroot) has not been written.
Error in TROOT::WriteTObject: The current directory (Rint) is not associated with a file. The object (h1f) has not been written.

Also, I have to edit $ROOTSYS/etc/system.rootrc because I need a Root and Qt3.3.8 integration. I am using Root v5.26

GUI specific settings.

Gui.Backend: qt
Gui.Factory: qt

Thanks in advance

Frances

Hi Francis,

did you get any further with this. Does your installation of ROOT come with the $ROOTSYS/lib/libGQt.so lib? If not rebuild it with qt enabled (using --enable-qt).

Cheers, Fons.

VIVE L’AMOUR!
I’m sorry but is it not so that the VERY LAST version of ROOT that supports Qt-3 is ROOT v5-18?
All newer ROOT versions REQUIRE Qt-4?
I am stupid. No?
Pepe Le Pew.

No the last version supporting Qt3 was v5-22, with v5-24 we went Qt4 only. So indeed v5-26 used by Francis will not work.

Cheers, Fons.

VIVE L’AMOUR!
sorry, but ROOT v5.22 configure will not recognize Qt-3 at all, not even if you try to enforce it using “./configure --with-qt-incdir={QTDIR}/include --with-qt-libdir={QTDIR}/lib” :^o

ROOT v5.20 configure will indeed recognize Qt-3 (you need to set the “QTDIR” environment variable), but this ROOT version seems to be a bit strange “transition” version - between older v5-18 and newer v5-22. I don’t remember now why I try to avoid v5.20, but there were some reasons, so I prefer to stay with the “last good” version v5-18 (although it will not compile on newer systems and/or under newer compilers). :-({|=

A pitiful case, am I not?
Pepe Le Pew.

Ok, we have an error in the ./configure comments, as v5-22 states to still support qt 3. :wink: Yes, pity you have to stay on an old ROOT because of an old version of Qt.

Cheers, Fons.

VIVE L’AMOUR!
if anybody wants to use the old ROOT v5.18.00-patches version, then I recommend applying the attached small set of “fixes” (on top of the current svn source code). :-({|=
A pitiful case, am I not?
Pepe Le Pew.
BTW. Note also that the current Ubuntu 10.04 distributes ROOT v5.18.00 in form of a set of binary packages.
v5.18.00-patches.34424.fixes.tar.gz (107 KB)

Hi. I have built with
./configure linux --enable-qt

Checking with
./configure –-help

it says that the target linux = i386 Linux with gcc >= 3.

I am using UBUNTU 9.10, i686 architecture, with gcc/g++ 4.4 Should the setting target=linux be an issue? What is the appropriate target for i686?

Moreover, I am running two UBUNTUs of the same version using VirtualBox3.1.6. In the UBUNTU#1) I am using ROOT binaries and UBUNTU#2)I am building from souce with I the above problem I am faced with. I am able to run simple ROOT macros with UBUNTU#1, however not on the second. Are any of these issues?

Thanks again
Frances

Hi

To complement Qt3.3, I tried the following lower root versions with gcc 4.4.1

  1. Rootv5.20, the following error:

bin/rmkdepend -R -fcint/cint/src/Type.d -Y -w 1000 – -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -Icint/cint/inc -Icint/cint/src -Icint/cint/src/dict -pthread -I. -D__cplusplus – cint/cint/src/Type.cxx
g++ -O2 -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -Icint/cint/inc -Icint/cint/src -Icint/cint/src/dict -pthread -I. -o cint/cint/src/Type.o -c cint/cint/src/Type.cxx
cint/cint/src/Type.cxx:128:15: error: missing binary operator before token "("
cint/cint/src/Type.cxx:141:15: error: missing binary operator before token "("
make: *** [cint/cint/src/Type.o] Error 1

  1. Root5.18, the following error:
    g++ -O2 -pipe -m32 -Wall -W -Woverloaded-virtual -fPIC -Iinclude -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -Icint/src -pthread -o cint/src/Type.o -c cint/src/Type.cxx
    cint/src/Type.cxx:128:15: error: missing binary operator before token "("
    cint/src/Type.cxx:141:15: error: missing binary operator before token "("
    In file included from cint/src/Type.cxx:18:
    cint/src/common.h: In member function ‘bool G__ifunc_table::operator<(const G__ifunc_table&) const’:
    cint/src/common.h:1032: warning: suggest parentheses around ‘&&’ within ‘||’
    make: *** [cint/src/Type.o] Error 1

Frances

VIVE L’AMOUR!

I quote my previous mail about ROOT v5-18-00-patches svn source code … 8-[

The “newest” compiler, that I was able to use, was gcc 4.2.1 (openSUSE 10.3, i586). <img src="/uploads/default/original/2X/8/84c2fe9464a4066c00e1bd5978e913e7869cbb07.gif" width=“22” height=“16” alt=":-"" title=“Whistle”/>
Later, I was NOT able to use gcc 4.3.2 (openSUSE 11.1), NOR gcc 4.4.3 (Ubuntu 10.04.1 LTS, i686). ](*,)

Well, you might try to get the Ubuntu “root-system” 5.18.00 version configured with Qt3 and then compile it (though I do not know how many official ROOT patches from snv are in, I have never tried to compile it myself):

https://launchpad.net/ubuntu/+source/root-system

https://launchpad.net/ubuntu/+source/root-system/5.18.00-2.3ubuntu7

http://archive.ubuntu.com/ubuntu/pool/universe/r/root-system

If you decide to use the standard Ubuntu “root-system” binary packages (I was using them, but I did not care about Qt add-ons, and they configured it with Qt4 anyhow, I believe), make sure you execute:

export LD_LIBRARY_PATH="/usr/lib/root/5.18:${LD_LIBRARY_PATH}"

This is because they have a problem in the “root-system” configuration. Some libraries are in “/usr/lib/root” (that’s what you get when you try “root-config --libdir”), but some libraries are only in “/usr/lib/root/5.18”.

BTW. The “linux = i386 Linux” target if fine for your “i686”. It’s the compiler which will decide what “target” it really uses. Try “gcc -v”, you will see something like “Target: i586-linux-gnu”, for example. :-({|=

A pitiful case, am I not?
Pepe Le Pew.