rootlogon.C in makefile


I have a rootlogon.c file that works just fine when I run or compile my code on ACLIC.

I am trying to use a very simple makefile (attached). If I do gEnv->Print() in my compiled code, I see that it is loading my file:
Rint.Logon: /home/lpesantezval/Downloads/Belle2Styles/rootlogon.C [User]

But if I do gStyle->Print(), the style used is a default one:
“OBJ: TStyle Modern Modern Style”

Instead of my style:
“OBJ: TStyle BELLE2 Belle2 style”

Thanks in advance!
makefile.txt (502 Bytes)


that was very minimalistic, sorry, I couldn’t get what the suggestion is

For example, search for the “rootlogon.C” string in the TRint class description and/or see the TRint::ExecLogon() method source code.

sorry to revive this thread. I tried the suggestion that was posted previously, but some of the style parameters are not changed when read from the logon file. In the attachements the working.cxx file can be compiled with the interpreter and the not_working.cxx file with the makefile. As you can see in the pdfs, the changes in pad margins are not applied while the other features are. I am using root-v6-04

not_working.pdf (13.8 KB)
working.pdf (13.8 KB)
makefile.txt (430 Bytes)
rootlogon.C (350 Bytes)
not_working.cxx (464 Bytes)
working.cxx (746 Bytes)