Rootcint Include Files

I am trying to generate a dictionary. My .h file for my class includes another header file. When I try to generate the dictionary rootcint complains that it can’t find the included file. I tried to use the -I directive, but can’t get it to work. What is the correct syntax. Please see output below. Thanks in advance.


/usr/local/bin/rootcint /Users/Jon/Documents/Physics\ Research/BNL\ Research/Developer/Icool\ Tools/TICoolEmbeddedCanvas/TICoolEmbeddedCanvasDict.cxx -c /Users/Jon/Documents/Physics\ Research/BNL\ Research/Developer/Icool\ Tools/TICoolEmbeddedCanvas/TICoolEmbeddedCanvas.h /Users/Jon/Documents/Physics\ Research/BNL\ Research/Developer/Icool\ Tools/TICoolEmbeddedCanvas/TICoolEmbeddedCanvasLinkDef.h
Error: cannot open file “icoolroot.h” /Users/Jon/Documents/Physics Research/BNL Research/Developer/Icool Tools/TICoolEmbeddedCanvas/TICoolEmbeddedCanvas.h:15:
Warning: Error occurred during reading source files
Warning: Error occurred during dictionary source generation
!!!Removing /Users/Jon/Documents/Physics Research/BNL Research/Developer/Icool Tools/TICoolEmbeddedCanvas/TICoolEmbeddedCanvasDict.cxx /Users/Jon/Documents/Physics Research/BNL Research/Developer/Icool Tools/TICoolEmbeddedCanvas/TICoolEmbeddedCanvasDict.h !!!
Error: /usr/local/bin/rootcint: error loading headers…

Try something like:
rootcint -f dict_file.cxx -c -p -I/include/path1 -I/include/path2 header_file1.h header_file2.h LinkDef.h

-l didn’t work. Shouldn’t -I work? I tried that and it didn’t work either. Why should this be so difficult?

Does anyone know how to include a header file when creating a dictionary? Shouldn’t -I work?