Rootcint and the -p option

I’m compiling code that I’m not too familiar with yet. It uses rootcint to generate dictionaries. It passes the “-p” option and causes the build to choke. I’m using ROOT 4.02.00, gcc 3.4.2, on a FC3 platform.

There’s no documentation on the -p option for rootcint. Is this the same option as cint? If so, are all of the cint options available for rootcint?

In any case I tried out a very simple example from the ROOT tutorial … ionaryNOIO
"Dictionary Generation for Interactive Access Without I/O and RTTI"
And it worked just fine as documented. Meaning “rootcint -f mydict.C -c MyClass.h” successfully generated the dictionary.

However when I add the -p option I get the following error message…

[olivas@localhost ~/rootcintTest]$ rootcint -f mydict.C -c -p MyClass.h
Error: class,struct,union or type T not defined FILE:/usr/local/root_v4.02.00/root//cint/lib/prec_stl/vector LINE:44
Error: Unexpected EOF G__exec_statement() FILE:/usr/local/root_v4.02.00/root//cint/lib/prec_stl/vector LINE:209
Error: Unexpected EOF G__fgetname():2 FILE:/usr/local/root_v4.02.00/root//cint/lib/prec_stl/vector LINE:209
Error: Unexpected EOF G__fgetvarname():2 FILE:/usr/local/root_v4.02.00/root//cint/lib/prec_stl/vector LINE:209
Error: Unexpected EOF G__fgetstream():2 FILE:/usr/local/root_v4.02.00/root//cint/lib/prec_stl/vector LINE:209
Syntax Error: Maybe missing ‘;’ FILE:/usr/local/root_v4.02.00/root//cint/lib/prec_stl/vector LINE:209
Error: Illegal pointer operation (tovalue) FILE:(tmpfile) LINE:2
*** Interpreter error recovered ***
Warning: Error occured during reading source files
Warning: Error occured during dictionary source generation
!!!Removing mydict.C mydict.h !!!
Error: rootcint: error loading headers…
[olivas@localhost ~/rootcintTest]$

This is the exact same error message I get when trying to compile analysis code. If I remove the -p the build chokes even earlier. Any information on what the -p option is for and how to get this working would be greatly appreciated.

Hi Alex,

We have had similar report which I have not been able to reproduce (I do not have access to a gcc 3.4.2/FC3 platform). The best would be for me to obtain (temporary) access to your machine to fully reproduce the problem.