ROOT6 and gcc5.4

Hi,

After a recent ubuntu upgrade (16.04LTS) I can no longer install ROOT6. Apparently it is incompatible with gcc5.4. Looking at the forum I understood that gcc5.x is not supported by clang. However, I could not understand whether there was a simple and robust workaround to make it work.

As a desperate measure, I also tried to install ROOT5.34 but it also fails*.

Thank you for your help.
Adrian

core/utils/src/rootcint_tmp.cxx:817:51: error: invalid conversion from ‘void ()(const char)’ to ‘void ()(char)’ [-fpermissive]


Hi,

Thank you for the pointers. I actually read these posts and try it myself. Unfortunately it does not seem to work:

$ cmake “-D_GLIBCXX_USE_CXX11_ABI=0” /home/adrian/Downloads/root-6.06.06
– Found GCC. Major version 5, minor version 4
CMake Error at cmake/modules/CheckCompiler.cmake:61 (message):
Found GCC compiler with new ABI. Cling does not support the GCC 5 ABI yet
Call Stack (most recent call first):
CMakeLists.txt:35 (include)

– Configuring incomplete, errors occurred!

Thank you

Sorry to insist, I tried the command you posted but I get the same error message.

Remove your “build subdirectory” completely and start from scratch again.

Maybe you also need to download the latest sources? or “git pull”

Alternative way would be: