ROOT x11 errors on Ubuntu 14.04


I am running ROOT remotely on a Red Hat Server through my laptop, which is running Ubuntu 14.04. I ssh using the -X flag, but when I try to open a TBrowser, I get the error:

root [0] TBrowser a Error in <TGClient::TGClient>: can't open display "localhost:15.0", switching to batch mode... In case you run from a remote ssh session, reconnect with ssh -Y

I have tried using -Y instead of -X and that didn’t fix the error. I have tried to examine the /etc/ssh/sshd_config file on the server, but I am unauthorized to view it. A while back when I was running the same code on OSX I wasn’t having these issues. Any other Ubuntu users encounter a similar problem? I have tried everything that I can think of and everything that google has suggested.


Try to login to your remote server using “ssh -X -Y” and then in this new remote session window try to run “xterm” (see if you get any warnings / errors).
If the new remote “xterm” window got displayed, then try to run your “root” in it (and execute “new TCanvas()” or “new TBrowser()” in order to test its X11 graphics).

you can follow the instruction of :

I think you lost the step of
  1. In Bash prompt, enter “export DISPLAY=localhost:0.0” to connect to Xming host over TCP/IP and enable UI apps from Bash
  2. Install x11-apps with “apt-get install x11-apps”