ROOT (v6) for Linux Mint

I was trying to download ROOT v6.10/08 for Linux (Mint), by using different links used for Ubuntu. None of them worked, I tried to add them to the bash using the terminal but nothing is working.(using Binary distributions)

If anyone has any link for Linux, Mint version (64-bit) please post it.

Thank you

What do you get from: gcc --version

This is what I get if I type gcc --version:

" gcc (Ubuntu 5.4.0-6ubuntu1~16.04.9) 5.4.0 20160609
Copyright © 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

I guess you should try the “Ubuntu 16 gcc5.4” binaries.

1 Like

Binary distributions of ROOT are specific to Linux distributions because they have different settings for the system, different defaults for the compiler, etc. As @Wile_E_Coyote said, the best choice for you would be to download the binaries for Ubuntu 16, since your Linux Mint is based on it. However, you have to make sure that you have ROOT’s dependencies installed too. For example, you may need to install TBB from the system, etc. If you install the packages listed here, I think that the Ubuntu binaries will work for you. However, please do not install davix-dev as the version in Ubuntu 16 is too old and doesn’t work properly with ROOT. I hope this is enough for you to get ROOT installed. Otherwise, you can follow the recipe inside the Dockerfile for Ubuntu to build ROOT from sources. Cheers,

1 Like

@Wile_E_Coyote @amadio Thank you so much, it has now worked!
I think my problem was with the ROOT dependencies, some of them were not installed.

Thank you once again :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.