Root v6-12-06 make error in ubuntu 17.10

Please provide the following information:

ROOT Version (e.g. 6.12/06):
Platform, compiler (Ubuntu 17.10, gcc7.2.0):


I am using ubuntu 17.10 and installed all the prerequisites listed in the webpage:

and then configured using classic configure/make method of building ROOT

./configure --enable-roofit --enable-fftw3

and then,


But it fails with the error

/usr/bin/ld: cannot find -lXMLParser
collect2: error: ld returned 1 exit status
/home/higgs/Downloads/root/hist/unfold/ recipe for target ‘lib/’ failed





Thanks in advance!

Please try a sequential compilation (make -j1), this version may still be affected by a bug that breaks the parallel build. Cheers,

1 Like

Have you tried the recommended building procedure (which actually uses CMake)?


1 Like

make -j1 gives the same error

Yes, I did tried that in the beginning but it failed too then I returned to the classic configure/make method of building ROOT.

Make sure that you have the “libxml2-dev” package installed.
Use “CMake / make” with ROOT 6 (the classical “configure / make” based method is known to be broken, i.e. not supported any more).

Please note also that the ROOT Team provides ready to use binary distributions and the “Ubuntu 17 gcc7.2" is one of the supported systems.

1 Like

Dear Wile,

Yes, I am sure that I have the “libxml2-dev” package installed. As you can see the locate output too.
As mentioned before I already tried Cmake before which failed too, that’s why I returned to the classic configure/make procedure.
Yes, I tried the binary distributions which works well. But I wanted to build the root myself…

Are you sure that error is the first one you get? The make-based build system is deprecated in 6.12 and will be removed in 6.14. If you can try with CMake instead, it should work. Please attach a full build log so that I can try to diagnose what exactly is the problem. Thanks,

1 Like

OK I tried with CMake again…Here the complete steps:
1. Downloading ROOT

git clone
cd root
git checkout -b v6-12-06 v6-12-06

2. Building Prerequisites:
previously done already

sudo apt-get install git dpkg-dev cmake g++ gcc binutils libx11-dev libxpm-dev libxft-dev libxext-dev
sudo apt-get install gfortran libssl-dev libpcre3-dev xlibmesa-glu-dev libglew1.5-dev libftgl-dev libmysqlclient-dev libfftw3-dev libcfitsio-dev graphviz-dev libavahi-compat-libdnssd-dev libldap2-dev python-dev libxml2-dev libkrb5-dev libgsl0-dev libqt4-dev

3. Installing using CMake
a. created another build directory mkdir root_build outside the root directory.
b. cd root_build
c. cmake -Droofit=ON -Dfftw3=ON /home/physics/Downloads/root/
d. cmake --build .
e. the added these lines in the .bashrc : source /path/to/install-or-build/dir/bin/

And, this time it seems it was successful

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.