ROOT uninstalls on reboot

Hi, I built root from source according to … oot-source

and root will run fine after compiling. However, after restarting linux root will no longer run. I get the message The program ‘root’ is currently not installed. Can anyone help me with this?


Well, in fact, ROOT doesn’t uninstall itself, it is simply not found in your PATH… If you look carefully at “Location independent installation”, under the point 3) Add bin/ to PATH and lib/ to LD_LIBRARY_PATH (with . bin/ And you have to do that for each new session, unless you add those variables in your ~/.bashrc

Cheers, Bertrand.

ah thank you, sorry for wasting your time, i still get confused sometimes with linux and root. What do I need to add to my .bashrc? Would it be just . bin/ or do i need to cd to the directory where root was installed.


i added

. home/user/root/v5-34-00-patches/bin/ to my .bashrc located in the user directory, as well as the .bashrc located in the home directory. However, root is still not found after a reboot. By running the command manually in the terminal after login it does work, and linux can find root - which leads me to believe that the .bashrc is not doing the job. Any thoughts?

source /home/…

BTW. Remember to open a new terminal after you modify “.bashrc” (so that the new settings are loaded in the new session).

okay i added the correct path now to .bashrc. When i open a terminal i get the warning

bash: /…/…/bin/ Permission denied

What should i do?
thanks for your patience

put in your “.bashrc” (instead of the “.” character, you can put the “source” word there, but many “sh” related shells do not support it):
. /home/user/root/v5-34-00-patches/bin/

great, it is working now - thanks for your help Wile E. Coyote and bellenot