ROOT uninstall erased some of my system files (/usr/share)

Hi all,

I installed the latest version of ROOT tonight from subversion (5.33). However, my RooFit code was breaking, so I figured I would uninstall this new version of ROOT and then checkout a tagged version from an earlier release (5.30).

I had installed ROOT under /usr/local/. Naively, I figured I could type ``make uninstall". There is a rule for that in the Makefile and it seemed to be removing what I thought was all the ROOT files.

However, after I closed the terminal and then tryed to do other work in a different terminal, I started getting errors from vim, Chrome, etc. After some poking around, I came to the conclusion that the ROOT rule ``make uninstall" removed /usr/share/ on my system.

I am running Debian, if that makes any difference to the directory structure.

If anyone at CERN in ROOT devel could try running a ``make install" and tell me if it destroys any of their system files like /usr/share/, that would be great. On second thought…don’t run that, just in case. But could you let me know what happened here?

I’m going to have to do a fresh reinstall of my system.



can you let me know how exactly you ran ./configure. I tried doing:

./configure --prefix=/usr/local
make -n uninstall [notice the -n to not execute this step]

and the output does not show that /usr/share was going to be deleted.

Of course this should not happen, but generally it is simpler to install ROOT without --prefix.

Cheers, Fons.

Hi Fons,

I wiped out my system again. About to reinstall. This sucks.

I found the problem…it’s the fontdir option on my system.

./configure --prefix=/usr/local --fontdir=/usr/share

My fonts are installed under /usr/share. When I run the previous configure command and then this

make --just-print uninstall | & grep share

I see this buried in the mix

rm -rf /usr/share; \

This is a bug, right? The Makefile shouldn't be blowing away whole directories where you pointed it to find libraries, right? Regardless of where my system (Debian) is installing things, the Makefile should never remove a whole directory where the config file was told to look for particular libraries.


Auw, thousand apologies and thanks for finding it. This is indeed a huge bug and should not happen. Clearly we did not check this case and expected the font not to be in /usr/share. Will fix asap.

Cheers, Fons.

Thanks much, Fons.

This should now be fixed in the v5-34-00-patches and the trunk (r48394).

Cheers, Fons.