ROOT Ubuntu 13.10 and OpegGL problem/ bug?

Dear ROOT’ers
I tried to install FairROOT, as far as I know it’s uses unmodified configuration files from ROOT - and this scripts can’t find libGLU/libGLUmesa, so after installations openGL doesn’t works in ROOT.
Does anybody get similar problem?
I fix this problem by adding /usr/lib/x86_64-linux-gnu/mesa to list of directories where scripts look for those files. Probably Ubuntu developers decided to move those files in another places, so if this problem is on all versions of ubuntu-like newest system maybe configuration script should be modified.

Well, if configure was not able to enable OpenGL, this means you do not have xxx-dev installed (I do not have ubuntu now, so I can not check exact names, I’m sorry). Check in ubuntu software center (I’m not even sure I named it right :slight_smile: )

apt-get install libglu1-mesa-dev, it seems.

You don’t understood me - the problem is not lack of those libraries - configure just can’t find them because they are in /usr/something-lib/mesa instead ob /usr/somethig-lib/.
When I change configuration file - it started to work - and i didn’t have to install this package because it was there at first time when this error occurred). So my question is not “how to fix this” but “do you have similar problem on ubuntu 13.10”.

My answer is “No” then.

On my freshly installed Ubuntu 13.10, with all required libraries and headers installed via the software centre, ROOT’s OpenGL libraries were built successfully.

P.S. I have a software OpenGL though.

Hi Timur,

Do you also get the libs in the subdirectory? Are there symlinks created in /usr/lib?


[quote=“matevz”]Hi Timur,

Do you also get the libs in the subdirectory? Are there symlinks created in /usr/lib?


Hi Matevz, mesa libs are in /usr/lib/x86_64-linux-gnu/ in my case. I guess if you install propriety drivers you can have a libGLU installed in some different directory, otherwise I do not understand why OP has it in the ‘mesa’ subdir, I have the same 13.10 (64-bit).

I think tpochep may have right because I have AMD proprietary drivers, so problem is solved.