Root slow startup after upgrading to Sierra 10.12.6

After upgrading to Sierra, ROOT takes ~5 sec to start. Could you please help me to solve it?
Please note that I know there are similar questions asked in forum, but they are complicated to follow (askers are advanced in Linux/Mac, not me.) I am new and I have to do it step by step.

Thanks in advance.

Please provide us more information at least about how you installed ROOT, what version, etc. Otherwise we are unable to help you.

I have ROOT 6.08 and 5.34 and both have the problem of delay in start up.
I do not remember how I installed it. But as far as I remember it was downloading the file and doing “make”.

Does this Root slow to start on Mac OS help?

Hi, Thanks Axel! It worked! So for the next person seeing this question, I typed:
“scutil --set HostName Mohammads-MacBook-Pro”

My host name was “Mohammads-MacBook-Pro.local” and I removed “local”. One can find their hostname by writing:

sudo -i
echo ‘OEA’ > /etc/.mdns_debug
root.exe -l -b -q

and after seeing, one should write:
"sudo rm /etc/.mdns_debug"
to change it to the first place.

It is discussed in the link Axel sent, but with a conversation which can be confusing for beginners.

Good! And FYI it’s worked around on the ROOT side since 6.10.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.