Home | News | Documentation | Download

ROOT production release v6.14/00 is out!


#21

Hi

I am new to jupyter

can we install python 2 and 3 on same system through Jupyter


#22

You could simply log on to lxplus7.cern.ch. Would that be a solution for you?


#23

Hi priyanka_120993, could you open a new topic for this?

Axel


#24

Hi Axel,
Sure, that works in principle. However bulk of the input samples I would like to work with are not stored on lxplus but in other machines where the OS is still SLC 6 (probably a fairly common situation). Is there a fundamental reason why an SLC 6.9 binary is difficult to centrally provide? I understand that CentOS 7 is the next step but this will really save a lot of hassle until the transition is complete. Normally I wouldnt mind not having the latest version of ROOT, but this one surely deserves an update :slight_smile:
Thanks
Halil


#25

Hi Halil,
SLC6’s compiler (GCC4.4!) is too old to build ROOT - GCC 4.4.0 is from 2009! Use LCG releases to create a custom environment (but then e.g. emacs is broken etc), or simply log on to lxplus7 where the compiler is old, too, but just recent enough.
Axel.


#26

Hi Axel,
I see, I do get the general idea that lxplus7 is the recommendation from ROOT side.
But given than CentOS 7 is not the industry standard yet, neither in lxplus nor in fnal lpc (not even available on most nodes for batch processing etc), is there any possibility of accommodating this transitional period from the ROOT end? Or is it simply not possible to compile ROOT in SLC6.9? If it is possible, I would really appreciate a bit more guidance or a recipe on that front.
Thanks
Halil


#27

Hi,

  • CentOS7 is the industry standard. It’s from 2014, i.e. four years old.
  • CERN IT will switch the lxplus alias to CentOS7 next summer https://indico.cern.ch/event/676324/contributions/2953740/attachments/1649534/2637504/CERN_Site_Report_-_HEPiX_Spring_2018.pdf
  • The SLC6 compiler is too old to build ROOT. I can not. Doesn’t compile.
  • You can build your own compiler on lxplus, but then you need to build all dependencies, too. That’s what “LCG releases” in /cvmfs/sft.cern.ch/ provide; the newest one (containing ROOT v6.14/00) isn’t out yet, might take a couple of weeks. We’re not doing that; we (the ROOT team) recommends to use an OS that is recent enough to support the newest ROOT. I.e. younger than 9 years…

I’m curious - what’s stopping you from using lxplus7? You can access the same files from lxplus and lxplus7, no difference.

Cheers, Axel.


#28
  1. The LCG dev4 release has 6.14. Use source /cvmfs/sft.cern.ch/lcg/views/dev4/latest/x86_64-slc6-gcc7-opt/setup.sh

  2. @Axel, do you have any idea why it’s taking so long to switch to CentOS 7? At this rate, CentsOS 8 will be out by the time the grid supports CentOS 7.

I’m curious - what’s stopping you from using lxplus7? You can access the same files from lxplus and lxplus7, no difference.

@hsaka is probably using an SLC6 only Tier 3.


#29

@hsaka depending on what you use from ROOT (it’s a large toolkit/framework!) you may (or may not) have a look at go-hep/rootio that can read ROOT TFile, TTrees and TH{1,2}x.
Also, as it’s pure Go, you can compile to completely static binaries (for Linux, Windows, macOS, FreeBSD, …) w/o caring for the target toolchain: Go binaries compiled on, say, Ubuntu-14.10 will happily run on Centos7 or SLC6.
the target system won’t even need to have the Go toolchain installed.
no strings attached :slight_smile:


#30

No strings attached and not a lot of features either :wink:

@sbinet - I’m all in favor of good competition and I don’t mind you using the forum to advocate for your software, but please stay within reason. You have posted to a topic that announces ROOT 6.14/00. I do not find your comment helpful in this context, as it doesn’t address an actual technical issue with an alternative implementation but is a blanket “use mine instead”. Thank you for your understanding, please consider re-wording your comment. (Else I will go shopping for a couple of trolls that post “use R”, “use Mathematica”, “use Octave”, “use python”, “use Perl”, “use Excel” to every ROOT post and we can close the forum.)


#31

@Axel

I do not find your comment helpful in this context, as it doesn’t address an actual technical issue with an alternative implementation

I am sorry you felt it that way.

I am always very careful not to be too pushy (that’s subjective), not to oversell Go (I also mention uproot (especially b/c I find it a vindication of the approach taken by go-hep/rootio) and do help people with regular C++/ROOT or PyROOT).
I am also always very careful to mention go-hep/rootio only when after somebody from the ROOT team has answered and when that answer isn’t completely satisfying (that’s somewhat less subjective a statement).

in the case at hand, the OP may not be able to switch from SLC6 to Centos7 for many $REASONS.
how is this not an actual technical issue?
I’ve argumented and explained why it could be a good fit (with a foreword caveat) for the particular situation.
In my book, that’s far from being a troll.

not a lot of features either

true. (at least wrt ROOT I/O. I’d disagree wrt being able to perform physics analyses, though.)
still, that stings a bit. (while I have a few users, I am the only one working on rootio, and only 20%. and most probably not as clever as the ROOT team.)

but do tell me what I need to reword and I’ll gladly comply.


#32

A post was split to a new topic: Wrong TMVA results in v6.14


#33

Yes I agree it’s annoying - CentOS is the conservative Fedora, and CERN is deploying this in a super conservative way. AFAIK the goal was to have grid nodes and lxplus move at a similar pace, but these days it matters far less than it used to. Anyway - we have lxplus7, so let’s use that!


#34

I tried this on my Ubuntu 16 installation under WLS (win 10) and it worked fine! Thanks


#35

Dear all,

Does anuone know about CMSSW ?

THANKS


#36

Please check with your CMS framework people.


#37

Ok thank you

Le mercredi 27 juin 2018, Axel Naumann root.discourse@cern.ch a écrit :


#38

Hi Axel,

I was wondering whether I could get the location of the file so I can make the appropriate changes and install ROOT correctly. Can I also use the -jN argument to enable all cores of my computer, or is this already done by default when running the command on Mac, thanks again.
cmake/modules/SearchInstalledSoftware.cmake

I am running Mac OS X 10.13.5, and have updated to the new CMake 3.11 version.


#39

Which file’s location are you looking for? The one you quoted yourself? That’s in ROOT’s source directory once you download the sources or check it out.

Use -j 8 or whatever when running make; if you use ninja then it does it automatically.

Everyone, please consider opening a new topic if it’s not directly related to us releasing ROOT. I will close this topic now to increase the motivation for that :wink:


#40