Root on Ubuntu 10.04 no graphics


I’ve been trying incessantly to get root installed in Ubuntu 10.04 but I’m having problems.

Version stuff:
ROOT 5.30/01 (tags/v5-30-01@40633, Aug 18 2011, 16:46:17 on linuxx8664gcc)

Compiled with --gminimal.
Enabled support for builtin_lzma, shadowpw, shared, x11.

Linux livlhcb010 2.6.32-33-generic #72-Ubuntu SMP Fri Jul 29 21:07:13 UTC 2011 x86_64 GNU/Linux

It seems to install fine but when I try to run a TBrowser I get the following error, and it never displays the window.

root [0] new TBrowser()

Error in TUnixSystem::DynamicPathName: GQt[.so | .dll | .dylib | .sl | .dl | .a] does not exist in /home/karol/root/lib/root:/home/karol/root/lib/root:/usr/local/lib/root:.:.:/home/karol/root/lib/root::/home/karol/root/lib/root/cint/cint/stl
(class TBrowser*)0x2086ed0

Please help,


for me the following works fine:

./configure --gminimal
new TBrowser

Did you specify in any .rootrc file that you want to use Qt as backend (from a previous install). That will not work.

Cheers, Fons.


I can’t find anything that would cause it. I’ve tried logging in as a different user. I’ve tried deleting /etc/root and reinstalling. I’ve even gone so far as making a chroot jail and still get the same error. Can you think of anything else that might cause the problem?

Where is it supposed to pick up from?


Please, look up for “~/.rootrc”, “.rootrc” and $ROOTSYS/etc/system.rootrc" to make sure none contains “GUI.backend” “qt”

Where is it supposed to pick up from?
[/quote] From $ROOTSYS/lib. is the ROOT plugin. It is built as soon as “configure” finds Qt header files installed and --enable-qt ordered.

Can you do

ldd $ROOTSYS/lib/*.so>libs.lst and upload “libs.lst” for us to see ?

[rcas6002] ~/<1>QTROOT/5.28/root/config/> ldd $ROOTSYS/lib/*.so | grep -i qt /afs/ => /opt/star/sl53_gcc432/qt4/lib/ (0xf7d29000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf75ce000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf7368000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf72fa000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf72bf000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf728c000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf6d6d000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf696c000) /afs/ => /opt/star/sl53_gcc432/qt4/lib/ (0xf7da8000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf764d000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf73e7000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf7379000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf733e000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf730b000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf6dec000) => /opt/star/sl53_gcc432/qt4/lib/ (0xf69eb000)

Ah crap, I missed one of the rootrc files. Got it now. Thanks for the help,