ROOT - No graphical output shown

Well, just read the “instructions” again and follow ALL STEPS that are shown there (just to make it clear … note that in the meantime there’s the “v5-34-08” production release advertised which you should probably take, even though I mentioned the older “v5-34-07” in my previous post as I was not aware of the new release).

I have had the same issue with root installed on OS X 10.8. I have followed the installation instructions explicitly, trying various build strategies (build from source, fink install, port install, pre-compiled binaries). In all cases, I have the same problem – no graphical display. Root will start properly, and I even see the splash screen on startup. However, if I type ‘new TBrowser’, I get a non-zero pointer return value, but no window pops up. Similarly, TCanvas windows fail to appear in response to TCanvas::TCanvas() and Draw() calls. On the other hand, if I run root as superuser, everything appears to work correctly (the TBrowser window appears as expected). I have tried this using both X11 and Cocoa with the same result. Any thoughts on what is going wrong with my root install?

UPDATE Problem solved! The culprit was a faulty plugin path declaration in my user .rootrc script. After removing the Unix.*.Root.PluginPath assignment from the .rootrc file in my home directory, everything seems to work correctly.