Root merging problem

while merging the root file I got the following error.
getting the same error from hadd method and also with TFileMerger

Error in <TBufferFile::CheckByteCount>: object of class TList read too many bytes: 1263111989 instead of 189370165
Warning in <TBufferFile::CheckByteCount>: TList::Streamer() not in sync with data on file /tmp/ROOTMERGE-116c4b3a-2756-11ec-88cc-1e03010abeef.root, fix Streamer()

How to solve this issue?
Thanks in advance

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Usually this indicates that one of the input file is corrupted and may not be readable/useable. Can you try to reduce the number of input files that still produce the error to check whether this is really the case?

while reducing input file it merges successfully , this error is showing when adding more root files.
what i did was merged half input file separatly and it sucessfully merged. After that i try to merge that two files, but it shows the above mention error.

Which version of ROOT are you using? (If it is not the newest, can you try a newer one). Can you provide the 2 files that lead to the error?

ROOT 6.20/08
ROOT 5.34/30
ROOT 6.24/04
in every version showing same error

any suggestion

My apologies, It looks like I was too slow. The link provided is “expired”. Could you repost the file?

Thank you for the replay

@pcanal here is the link of file.