Root installation problem with Fedora Core 4

Hello Rooters,

I’ve been trying to install root (first version 4.04, then 5.02) on my Pentium 4 machine running Fedora Core 4. Installing Fedora Core 2 binaries did not seem to work. So I tried installing from the source code, but wasn’t able to do it either. There seems to be a problem somewhere in the g2root routine. ‘gmake’ gives me the following error:

g++ -O -o bin/g2root main/src/g2root.o
/cern/pro/lib/libpacklib.a /cern/pro/lib/libkernlib.a
-L /usr/lib/gcc-lib/i386-redhat-linux/3.2.3 -lg2c -lnsl -lm -ldl -pthread -rdynamic
/usr/lib/gcc/i386-redhat-linux/4.0.0/…/…/…/crt1.o(.text+0x18): In function _start': : undefined reference tomain’
collect2: ld returned 1 exit status
gmake: *** [bin/g2root] Error 1

This doesn’t look like something I could easily fix myself, so I was wondering if any of you Root experts have an idea on what to do with this.

(Btw, I had to modify my ‘Makefile.linux’ in the config/ directory and add a new library path:

-L /usr/lib/gcc-lib/i386-redhat-linux/3.2.3

to the F77LIBS flag, otherwise gmake crashed even earlier with the message that ‘g2c library was not found’.)

I’d be grateful for any ideas on this bug. Thanks in advance.


In Fedora Core 4 is gcc 4.0 with gfortran (no g77). Your cernlib is compile with old gcc (not compatibility with your gcc). I tryed compile cernlib 2005 with FC4 (gcc 4.0) but without result.

try this ROOT config option: ./configure --disable-cern

Thanks Jan! ‘config --disable-cern’ worked and I was able to run root. Last question though: Does the fact that I “disabled cern” mean that I won’t have access to some cern libraries? I found that in if you ‘enable-cern’, you load libHbook…

Thanks again,

You dont have access to ROOT h2root and g2root utilities (for more details see man h2root, man g2root)