ROOT installation on Windows 7

I want to use ROOT on Windows 7.
So I downloaded the last release of Version 5 in form of source, not binary.
I downloaded and installed Microsoft Visual Studio 2017 Version 15.9; I downloaded and installed CMake 3.13.3.
I did not set any PATH variable.
I ran CMake first to configure and then to generate.
Then I opened the command prompt and I entered the following command:

cmake --build . --target install

and I got some errors that I am not up to understand.
I ran the Windows batch file thisroot.bat by clicking on it twice in Windows Explorer.

Now if I try to call root from the Visual Studio command prompt the system answers that it can not find any “root”.
There is the build-directory/bin/root.sln file: if I call it then Visual Studio 2017 is opened.
But in no case do I manage to start the ROOT interactive application.

It is clear that I have not understood how ROOT has to be installed. I am sure that I did completely wrong steps.
But on the other hand I did not find much material to read on the installation on Windows.
So I need that somebody explicitly tells me what I have to do.

I have Windows 7 Professional with 64 bits.

Thanks in advance.

@bellenot, can you help here please?

1 Like


ROOT 5 can be built only with a verson of Visual Studio up to 2013. Visual Studio 2017 is for ROOT 6. Why don’t you simply donwload a binary?

Cheers, Bertrand

I downloaded and installed root_v5.34.38.win32.vc12.exe and now root perfectly works.
I still have two problems:

  1. On Microsoft’s website Visual Studio 2013 and Visual Studio 2012 are not available. But I understand that this doesn’t depend on you.
  2. I don’t have the file slits.C, which is mentioned in the Root Guide for Beginners.

Thank you anyway for your decisive help and thanks also to oshadura.

Did you try: Download Older Visual Studio Software?

I know, it is not part of the version 5 of ROOT, but you could simply copy the code and paste it in a file… Anyway, here it is: slits.C (1018 Bytes)

Cheers, Bertrand.

I went to the Visual Studio website page you have indicated. But when I pick ‘2013’ and then log in I am told that there are no downloads available for me.

Thanks a lot for slits.C.

You’re right, sorry then, there is nothing I can do… The only other solution would be to download ROOT 6.16/00 and install Visual Studio 2017 v15.7.6

You’re very welcome