ROOT installation: cmake command not found using old method

Dear experts,

I’m trying to install ROOT locally on my laptop following this link:

At first, I tried to use the current method, i.e. using make which I dont have on my machine. I therefore tried to install cmake but their site seems to be unreachable (I tried on Safari and Firefox). So, I decided to test the old method as described there:

I downloaded the source using git then configured.
But when I do “make”, I get the following error [1]

I thought that the old method did not need cmake at all. Why is it required at this stage ?

Thanks a lot for any help you could bring.


clang++ -O2 -DNDEBUG -MMD -MP -m64 -std=c++11 -stdlib=libc++ -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG -pthread -Icore/base/src -I/Users/charaf/root/core/textinput/src -I/Users/charaf/root/core/textinput/src -o core/textinput/src/textinput/TextInputContext.o -c /Users/charaf/root/core/textinput/src/textinput/TextInputContext.cpp
*** Configuring LLVM in interpreter/llvm/obj/ …
/bin/sh: cmake: command not found
make: *** [interpreter/llvm/obj/CMakeCache.txt] Error 127

Have you tried this site for CMake?
Also, what type of OS are you using? CMake is available in most package managers and is quick and easy to install.

You cannot use the old “./configure” based method with ROOT 6. You must use CMake 3.4.3 or newer.

Hi Ksmith, Wile_E_Coyote,

yes, this is the site I tried to reach but could not.
I’m using Mac OS Sierra 10.12.3

Thanks a lot for your help.


No, wait,

cmake website seems to be reachable now. Interesting. It is the same that I tried earlier.



CMake is available in bot ofe the popular macOS package managers: MacPorts and HomeBrew

Hi, if you are on High Sierra, I recommend getting ROOT via Homebrew.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.