Root install problem ubuntu 7.10

Hi, I am trying to install root on my ubuntu 7.10 PC, and am following the “make debian” from source instructions. After typing

sudo make debian

I get the following output:

make: pcre-config: Command not found
make: pcre-config: Command not found
OK, you’re on a Debian GNU/Linux system - cool
rm -rf debian
Update build/package/debian/changelog …build/package/lib/ 273: dch: not found
Setting up debian directory …
Copying README.Debian to debian/README.Debian
Copying application-x-root.png to debian/application-x-root.png
Copying changelog to debian/changelog
Copying compat to debian/compat
Copying to debian/
Copying copyright to debian/copyright
Copying libroot-clarens.overrides to debian/libroot-clarens5.17.overrides
Copying libroot-ldap.overrides to debian/libroot-ldap5.17.overrides
Copying libroot-mathmore.overrides to debian/libroot-mathmore5.17.overrides
Copying libroot-minuit.overrides to debian/libroot-minuit5.17.overrides
Copying libroot-mlp.overrides to debian/libroot-mlp5.17.overrides
Copying to debian/
Copying libroot-python.overrides to debian/libroot-python5.17.overrides
Copying libroot-quadp.overrides to debian/libroot-quadp5.17.overrides
Copying to debian/libroot-roofit5.17.copyrightn
Copying libroot-roofit.overrides to debian/libroot-roofit5.17.overrides
Copying to debian/
Copying libroot-ruby.overrides to debian/libroot-ruby5.17.overrides
Copying libroot-tmva.overrides to debian/libroot-tmva5.17.overrides
Copying libroot-unuran.overrides to debian/libroot-unuran5.17.overrides
Copying libroot.overrides to debian/libroot5.17.overrides
Copying directory po to debian/
Copying to debian/
Copying to debian/
Copying root-system-bin.mime to debian/root-system-bin.mime
Copying root-system-bin.png to debian/root-system-bin.png
Copying to debian/
Copying to debian/
Copying root-system-bin.sharedmimeinfo to debian/root-system-bin.sharedmimeinfo
Copying root-system-bin.xpm to debian/root-system-bin.xpm
Copying to debian/
Copying root-system-common.copyright to debian/root-system-common.copyright
Copying to debian/
Copying to debian/
Copying to debian/
Copying root-system-doc.overrides to debian/root-system-doc.overrides
Copying root-system-proofd.README.Debian to debian/root-system-proofd.README.Debian
Copying root-system-proofd.default to debian/root-system-proofd.default
Copying root-system-proofd.examples to debian/root-system-proofd.examples
Copying to debian/
Copying root-system-proofd.overrides to debian/root-system-proofd.overrides
Copying root-system-proofd.prerm to debian/root-system-proofd.prerm
Copying root-system-rootd.default to debian/root-system-rootd.default
Copying root-system-rootd.examples to debian/root-system-rootd.examples
Copying to debian/
Copying root-system-rootd.postrm to debian/root-system-rootd.postrm
Copying root-system-rootd.preinst to debian/root-system-rootd.preinst
Copying root-system-rootd.prerm to debian/root-system-rootd.prerm
Copying root-system-xrootd.default to debian/root-system-xrootd.default
Copying to debian/
Copying root-system-xrootd.overrides to debian/root-system-xrootd.overrides
Copying rules to debian/rules
Copying ttf-root-installer.config to debian/ttf-root-installer.config
Copying ttf-root-installer.copyright to debian/ttf-root-installer.copyright
Copying ttf-root-installer.dirs to debian/ttf-root-installer.dirs
Copying to debian/
Copying to debian/
Copying ttf-root-installer.templates to debian/ttf-root-installer.templates
fakeroot debian/rules debian/control
make: fakeroot: Command not found
make: *** [debian] Error 127

I had problems before, which required installing some libraries, but I do not know how to solve this problem. Some help would be greatly appreciated!

Thanks, Vinda.

Instead of using the make debian method, I tried using ./configure, and though it hasn’t worked yet, I am pretty sure I can get it to, so no worries at the moment!



Using the ./configure linux method I was able to install root successfully, although I must use the export ROOTSYS=/root/ commands etc to run it in a new terminal.