ROOT install failing


I am trying to install Root and am having trouble. I have been so far unable to find solutions to my problems on this forum or Google search. I’m trying to install on Ubuntu 16.04.3 with Oracle VirtualBox, running on Windows 10. I downloaded the Root source file (root_v6.10.08.source.tar.gz), saved it in a folder which I have shared with my Ubuntu virtual machine and extracted the source.

I first tried both the location independent and location dependent builds using cmake (as outlined in the INSTALL file in the source). For the location independent build, the first cmake …/root step seems to work well. I then type make –j2, however, and get this error:

Here are the contents of the PCRE-install-err.log file:

ln: failed to create symbolic link ‘/media/sf_radonc/root-build/share/man/man3/pcre16_assign_jit_stack.3’: Read-only file system
make[6]: *** [install-data-hook] Error 1
make[5]: *** [install-data-am] Error 2
make[4]: *** [install-am] Error 2
make[3]: *** [install] Error 2

I get a similar error with the location dependent build method.

I then tried another method: I cleaned, changed directory to the extracted folder and typed “make” into the console. Here is the error code I get then (sorry, only allowed to upload one image):

…/root/core/lz4/src/1.7.5.tar.gz: unexpected end of file
tar: This does not look like a tar archive
tar: exiting with failure status due to previous errors
/bin/sh: 11: cd: can’t cd to lz4-1.7.5
Make[1]: entering directory …/root/core/lz4/src
Make[1] *** no rule to make target ‘lib’. Stop.
Make[1]: Leaving directory …
…/root/core/lz4/ recipe for target ‘core/lz4/src/lz4.1.7.5/lib/liblz4.a’ failed

Does anybody have advice? Is there any more information I should provide? Does this have something to do with the fact that I am working in Ubuntu but operating on files in my Windows file system?

Thank you,

The problem was indeed that I was using shared folders, while I should have been working on the Linux file system.

Hi Henry,
I also have the similar problem with your second issue wondering if you could explain how to solve the issue. My error code :

*** Downloading
/bin/sh: 5: curl: not found
*** Building core/lz4/src/lz4-1.7.5/lib/liblz4.a…

gzip: /home/******/Downloads/root-6.10.08/core/lz4/src/1.7.5.tar.gz: unexpected end of file
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
/bin/sh: 11: cd: can’t cd to lz4-1.7.5
make[1]: Entering directory '/home/voquangnhat/Down

Thank you in advance

You need to install “curl”. For example, if you use Ubuntu, execute “sudo apt install curl”. Then try to run “make …” again.

oh, thank you so much. I very happy :slight_smile:

Hi Wile,
I have problem, Can you help me?

***/usr/bin/ld: cannot find -lXMLParser
collect2: error: ld returned 1 exit status
/Downloads/root-6.10.08/hist/unfold/ recipe for target ‘lib/’ failed
make: *** [lib/] Error 1

Thank you in advance

Try “locate” and if you get nothing, execute “sudo apt install libxml2-dev”. Then, I’m afraid, you will need to configure your ROOT completely from scratch again.

This is likely just a consequence of an earlier error. Could you send the output of make lib/

I want to install root framework. But I have problem, I have spent many time for Linux. This is in the first time I use Linux. I have read many things about install. I do follows directly, but I can’t install. Can you help me!
Thank you in advance!

Next time please open a new topic instead of appending to an unrelated and solved topic.

Please type make lib/ > make.log 2>&1 in a terminal and attach the file make.log.

Here’s the log file. Thank you in advance
make.log.tar.gz (158 Bytes)

You typed make make .... Please try again and upload the new file.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.