ROOT Install error ""

ROOT Version: 6.20.04
Platform: Ubuntu 20.04
Compiler: CXX

Dear root expert,

I tried installing ROOT 6.20.04 on Ubuntu 20.04 with Pythia6 and GSL using the cmake.

Configured as :
cmake -Dgdml=ON -Dbuiltin_gsl=OFF -Dmathmore=ON -Dpythia6=ON -Dgsl_shared=ON -DGSL_ROOT_DIR=/home/matt/test/support/gsl2.5 -DGSL_CONFIG_EXECUTABLE=/home/matt/test/support/gsl2.5/bin/gsl-config -DLIBXML2_DIR= /home/matt/test/support/libxml2 -DLIBXML2_EXECUTABLE=/home/matt/test/support/libxml2/bin/xml2-config -DPYTHIA6_LIBRARY=/home/matt/test/support/pythia6/ -DCMAKE_INSTALL_PREFIX=/home/matt/test/support/root-build/ …/root-6.20.04/

After successfully configuring and make.
I got an error for make install:
CMake Error at core/clingutils/cmake_install.cmake:51 (file):
** file INSTALL cannot find**
** “/home/matt/test/support/root-build/lib/”: No such file or**
** directory.**
Call Stack (most recent call first):
** core/cmake_install.cmake:70 (include)**
** cmake_install.cmake:199 (include)**

make: *** [Makefile:140: install] Error 1

I check the solution but I wanted to build it with pythia6 and GSL(not using gsl library from cernlib) for GENIE.

Also, I tried the same as here but still get the same error.

Can anyone please help me out?

Thanks in advance.

Hi @matt ,
could you please check whether the problem is still present in ROOT v6.24.02 , and if so does it really depend on the presence of Pythia6 and GLS? Do you need both for the problem to appear, and do they have to not be built-ins for the problem to appear?

@Axel might know what might cause this.


For Pythia, you can do the opposite. Build ROOT and then configure, make Pythia again. It worked perfectly for me.


Thanks for the reply.

I apologise for the late reply.

I do tried the version 6.24.02. I got exactly the same error.

Regarding the Pythia6 and GSL, if I am not wrong it was suggested not to used the inbuilt library for GSL( ie. cern gsl lib).


Thanks for the suggestions.

But should I configure ROOT again after this step?

I do need to link the file while configuring root which is a requirement for GENIE installation.

Hi @matt ,
we would need a recipe to reproduce this, or we have to debug this at a distance with your help.

Do you need both Pythia6 and GSL for the problem to appear? Is it enough that GSL is built-in for the problem to disappear?


Hi @eguiraud ,

Thanks alot.

Yes,I need both Pythia6 and GSL.

Here is the cmake command I need (It might be more clear)

cmake -Dgdml=ON -Dbuiltin_gsl=OFF -Dmathmore=ON -Dpythia6=ON -Droofit=ON -DGSL_DIR=/home/matt/GENIE/support/gsl2.5
-DGSL_CONFIG_EXECUTABLE=/home/matt/GENIE/support/gsl2.5/bin/gsl-config -DPYTHIA6_LIBRARY=/home/matt/GENIE/support/pythia6428/ -DCMAKE_INSTALL_PREFIX=/home/matt/GENIE/support/root-build/ …/root-6.20.04/

Hi @matt ,
sorry I probably wasn’t clear, my question is whether the problem is only present with GLS and Pythia6 turned on, or one of them is enough to reproduce it, or none of them.

Also do you need 6.20.04? Otherwise it might be worth trying with the more recent 6.24.04.


What’s your build directory - the directory in which you ran cmake?

And there’s a space after the = in -DLIBXML2_DIR= /home/matt/test/support/libxml2 that might be fatal…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.