ROOT install crash Ubuntu 12.10

Hello, I am somewhat a computing novice so please bear with me.
To begin with I have Windows 7 and needed to install ROOT so I installed cygwin and tried to install it that way. I can call root from the terminal and the splash screen will come up, although no prompt will. It allows me to type things and even switch lines but I cannot execute anything. After asking around and looking online I couldn’t find anything so decided my best bet would be to install Ubuntu.

I now partitioned my hard drive and installed Ubuntu 12.10. I followed the commands on the ROOT website for installation, although didn’t necessarily do it in order which may have been where my problem arose. I first ran the configure file and installed only the packages it needed to give me the OK to execute make. after I did this, I ran the make command and after about 15 minutes my computer shut off. I restarted it and reread all of the prerequisites to installing ROOT more carefully and and found that I didn’t have svn somehow. I installed that as well as all the other programs listed in the prerequisites for Ubuntu and ran the command to obtain the trunk, listed in the instructions. I then reconfigured and ran make again with the same result. My computer crashed after about 10 minutes. I have seen nothing anywhere about something like this happening in either the WIndows case or the Ubuntu case and would love it if someone could help me out or at least point me in the right direction. I am fairly new to linux and support forums in general, especially ROOT’s, so I am terribly sorry for any ambiguity in my post. Thanks in advance.

First, I think this page show how to install root on Ubuntu maybe it will help.
About crashing OS maybe this is a hardware problem (e.g. cooling), building ROOT can overheat CPU. Fastest way to check how building proceed is making again ROOT, if build process is interrupted not because of ROOT issue, you should see that each time when you call make new file/class is build.

Thanks a ton! It turns out that my computer was just overheating when I was compiling. As for the cygwin, I still have no idea, but it is working in Ubuntu