ROOT for Red Heat 7.3

Can I compile ROOT on Red Heat 7.3 with gcc 2.96? Or can I find such binaries?
I need ROOT’s version >= 5.12.00.

I tried compile ROOT on:[quote][mucha@he117-52 root]$ uname -a
Linux 2.4.20-20.7 #1 Wed Aug 20 19:28:05 EDT 2003 i686 unknown
[mucha@he117-52 root]$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-113)[/quote]
with default configure:
5.12.00g:[quote]g++ -O -pipe -Wall -W -Woverloaded-virtual -fPIC -Iinclude -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -D
In file included from cint/src/Api.cxx:21:
include/Api.h:26:19: ostream: No such file or directory
make: *** [cint/src/Api.o] Error 1[/quote]
5.14.00g and 5.18.00:[quote]gcc -O2 -pipe -m32 -Wall -W -fPIC -Iinclude -pthread -DINCLUDEDIR="/usr/include" -DOBJSUFFIX=".o" -o build/rmkdepend/cppsetup.o -c build/rmkdepend/cppse
cc1: Invalid option `32’
make: *** [build/rmkdepend/cppsetup.o] Error 1[/quote]
I hope this help, Jan

I hope this help, Jan[/quote]

Surely, I tried myself before posting here :slight_smile: And I had even fixed some problems (-m32 option or several compiling errors inside cint package), but I think, it’s a brute force solution to fix sources :slight_smile:. So, it seems to be impossible to compile ROOT >= 5.12 whith g++ 2.96.

Correct. And we do not want to spend time with this obsolete and buggy compiler.


And I do not expect this support from you. I’m only unlucky enough to have such platform and such compiler. :slight_smile: